Results 1 to 6 of 6

Thread: What happened?

  1. #1
    Sarcoth's Avatar
    Join Date
    Mar 2006
    Location
    Alabama
    Posts
    655

    What happened?

    This is the long version of what happened.

    A few weeks ago, I got an email from vBulletin about a security patch. It got lost in my email and I forgot about it.

    A couple days after that, my hosting company, Network Panda, suspended my account and told me sacredhaven.org was being used to send out spam email. I didn't know what they were talking about and I thought it was probably someone outside the domain using sh.org as the sender, and that was it. I asked them to remove the suspension and then I updated all the forum software.

    A few days later, they suspended me again and said the problem was still happening. At that point, I thought it wasn't the vb software at all because I updated it. I ended up updating everything else on the domain hoping that would take care of the problem. I then even started blocking all unused folders on my domain. I should also mention, the host deleted an entire folder in the software which caused some database problems. They did this b/c they said the bad files were located here. I could potentially recover from this though.

    A few days later, they suspended my account yet again! They told me they couldn't remove the suspension unless they got approval by their managers. They also removed yet another folder where they said the problem was occurring. This folder, unlike the first, caused major database issues. I'm not sure I can fully recover the old forum database after this happened.

    I spoke with Ashley and she gave me an idea and I took another look at the vBulletin software site. I then found a post talking about the security vulnerability that was crippling other vB sites. We were not the only ones hit. Apparently, from what I gathered, if you didn't apply the patch before being hacked, there was no way to stop it without deleting all files and using only the new ones. The reason is, they placed many disguised files on the server making it hard to figure out what was good or not. I informed Network Panda of this and they lifted the account suspension and I locked down all my folders. This way, I still had access to the crippled forums, but no one else did. This stopped the spam email and allowed me to try and pick up the pieces. Sadly, as I mentioned, the database was damaged due to not understanding what was going on. By Network Panda for deleting folders and by myself for not acting sooner.

    So, why did it take so long to get the new forums up and running?

    Last Friday, before I figured out what the problem was, I decided to move my domain services. This is the company that holds the domain names I own. I thought the problem could have had something to do with them and I wanted to cover all my bases. This automatically puts a lock on changing DNS settings. The move finally finished today.

    After I locked down the forums, I tried to contact Network Panda again to only discover they blocked me from submitting new tickets or even updating current tickets. From what I could tell, they have a block that appears after you submit so many replies or new tickets. I take this to mean they only provide so much support. I sent them an email and submitted a msg via another means, but i never heard back from them. Not a big deal at that very moment, but then while trying to fix the current forums, I got an error. I couldn't figure away around the error and I couldn't ask for help since I was blocked. Unacceptable.

    Thus, I started looking for a new hosting company. I settled on CrocWeb. They had a good deal that allowed me to get 3-years of service for 40-something dollars. Pretty good. Since my new domain services went into affect this morning, I was able to finally install the new vBulletin forums.

    I'm sorry that we lost the old forums. There is still a chance I'll get them back up, but they won't be open to the public any longer. I will provide some members access to them if you have a good reason for the access. I don't want to have to maintain more than one forum again, so I'm only going to keep this one going. I'm going to keep the addon mods to a small number. Ones that I feel are very useful and have little chance of causing any future issues.

    If you have any questions, let me know.

  2. #2

    Join Date
    Feb 2007
    Posts
    233
    Well that sucks, hate to hear that! I'm glad the forums are back up though! Missed being able to check in with people!
    Last edited by Zrikz; 2015/11/20 at 05:18 PM.

  3. #3

    Join Date
    Jan 2007
    Posts
    197
    Is there any way to just copy/paste the old forums onto the new, secure ones? I do occasionally like to see old messages and threads about stuff we did way back when. I'm nostalgic like that. If not, I understand. Thanks for everything you do, Sarc!

  4. #4
    Sarcoth's Avatar
    Join Date
    Mar 2006
    Location
    Alabama
    Posts
    655
    Quote Originally Posted by Zorus View Post
    Is there any way to just copy/paste the old forums onto the new, secure ones? I do occasionally like to see old messages and threads about stuff we did way back when. I'm nostalgic like that. If not, I understand. Thanks for everything you do, Sarc!
    Copy/paste would be a one by one post thing and would take too much time. Doing a direct copy from the old database would turn into a ton of errors. There's a lot to it and it's kind of hard to explain. I'm going to do my best, but I need the time to do it. Today I'm going to start working on some of those updates.

  5. #5
    Ashleylee's Avatar
    Join Date
    Feb 2014
    Posts
    178
    I too will miss some of the old stuff, but i also understand that its gone. Stupid hackers.

  6. #6

    Join Date
    May 2007
    Posts
    3
    I just thank you for keeping me involved in the community. Was missing you folks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •